<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	
	<link rel="profile" href="https://gmpg.org/xfn/11">

	<title>Pick-Six: Intriguing Players Available on Day 2 of NFL Draft &#8211; NBC Connecticut</title>
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC Connecticut &raquo; Feed" href="https://www.nbcconnecticut.com/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.nbcconnecticut.com/_static/??-eJyVjUsOwjAMBS+EawKCrhBncT6AhetGcaoqtydCArHpgu28GT1cM4RZa9KKWZY7qyFFEGqpGKgPGOyXxFseOtnhf923YQ2yxGTvObJV9DKHJwj7QqWh1SZpmFg3CrIH91/bVij2CTyVj3KdLu40nkfn9sfDC/nYV1c=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link crossorigin="anonymous" rel='stylesheet' id='font-awesome-css'  href='https://use.fontawesome.com/releases/v5.9.0/css/all.css' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://www.nbcconnecticut.com/_static/??-eJydz0kOwjAQRNELEQ/x0PYCcRa73SEWHhBxxPUJCw5A1r/0pOLv54S9DWqDj5UqbbxFnLYRRu6NY8nfEvdcEsftiL2F+mQyKec1WAvSWE9eG+1ZzY0dmwv/08Rea28s0kKOjANyBiCoSCgYrnt7nJbvpcdQWJyNADWDMpGSni0RpdNmeI2MhZiWoLQ3Miw6oMAoKNAPvdWrPI5YMNrOH78Ners=' type='text/css' media='all' />
<script src='https://www.nbcconnecticut.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script type='text/javascript' src='https://www.nbcconnecticut.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZubmV6UWJKql5uZp5dVrKMPVJycn1eSmleiX5BTmp6ZV6yfmKKbk1iZWlSsm5eUDDIBIZCSVkC6LqAO+1xbQ1MLEzMTM0sL4ywAQvo6kA=='></script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4'></script>
<script>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script>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</script>
<script type='text/javascript' src='https://www.nbcconnecticut.com/_static/??/wp-includes/js/dist/i18n.min.js,/wp-content/themes/nbc-station/client/build/js/analytics.3bb9db65c214c92d8c9f.bundle.min.js?m=1584470665j'></script>
<link rel='https://api.w.org/' href='https://www.nbcconnecticut.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcconnecticut.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcconnecticut.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://www.nbcnewyork.com/news/sports/pick-six-intriguing-players-available-on-day-2-of-nfl-draft/5077036/" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcconnecticut.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcconnecticut.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	@media (max-width: 375px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.45) 0%,rgba(0,0,0,0) 100%), url('https://media.nbcconnecticut.com/2019/09/1920_CT-1.png?resize=1440%2C415'); }
	}
	@media (min-width: 376px) and (max-width: 768px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.45) 0%,rgba(0,0,0,0) 100%), url('https://media.nbcconnecticut.com/2019/09/1920_CT-1.png?resize=1440%2C415'); }
	}
	@media (min-width: 769px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.45) 0%,rgba(0,0,0,0) 100%), url('https://media.nbcconnecticut.com/2019/09/1920_CT-1.png?resize=1440%2C415'); }
	}
</style>
		<!-- Begin comScore Tag -->
		<script>
		var _comscore = _comscore || [];
		_comscore.push({ c1: "2", c2: "6035083" });
		(function() {
			var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
			s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
			el.parentNode.insertBefore(s, el);
		})();
		</script>
		<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
				window._taboola = window._taboola || [];
						_taboola.push({'article':'2260568', tracking:'_osource=taboola-recirc'});
						!function (e, f, u) {
					e.async = 1;
					e.src = u;
					f.parentNode.insertBefore(e, f);
				}(document.createElement('script'),
				document.getElementsByTagName('script')[0],
				'//cdn.taboola.com/libtrc/nbcots-network/loader.js');
		</script><script>
			window._newsroom = window._newsroom || [];
					!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/nbcots-wvit/newsroom.js');
		</script>
		<meta property="og:site_name" content="NBC Connecticut" /><meta name="google-site-verification" content="9DR-KZ3Q4cScEQmsx4MezWlQQHm13mICp8H7ZDGvvug" /><meta property="fb:app_id" content="81242742459" /><meta name="twitter:site" content="@nbcconnecticut" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="twitter:creator" content="@nbcconnecticut" /><meta name="article:publisher" content="http://www.facebook.com/NBCConnecticut" /><meta name="description" content="Six wide receivers were taken in the first round of the NFL draft and another half dozen could go on Day 2, when rounds two and three are completed." /><meta property="og:description" content="Six wide receivers were taken in the first round of the NFL draft and another half dozen could go on Day 2, when rounds two and three are completed." /><meta name="twitter:description" content="Six wide receivers were taken in the first round of the NFL draft and another half dozen could go on Day 2, when rounds two and three are completed." /><meta property="og:title" content="Pick-Six: Intriguing Players Available on Day 2 of NFL Draft" /><meta name="twitter:title" content="Pick-Six: Intriguing Players Available on Day 2 of NFL Draft" /><meta property="og:url" content="https://www.nbcconnecticut.com/news/sports/pick-six-intriguing-players-available-on-day-2-of-nfl-draft/2260568/" /><meta name="twitter:url" content="https://www.nbcconnecticut.com/news/sports/pick-six-intriguing-players-available-on-day-2-of-nfl-draft/2260568/" /><meta name="keywords" content="Utah, Boise State&amp;, McKinney, Ezra Cleveland, DE, Dobbins, running backs, Alabama, Georgia, Washington, Oklahoma, Kansas City, Wisconsin, NFL Draft Coverage NFL, board, Normal NFL, board, board, rivals, WR, Penn State&amp;, Alabama Alabama, Group of Five, LSU&amp;, SEC, Ohio State, Utah State, A.J., Big Ten, Green Bay Packers, RB, NCAA, round, draft, Kind of Looked, round, draft, season, game, round, run, catches, competition, season, game, seasons, pick, running back, safeties, dozen, running backs, none, plenty, receivers, Changes, Bengals Take, defensive back, five, Notre Dame&amp;#, combine, talent, champion, board, seasons, tackles, defensive end, tread, Thorpe Award, Colorado&amp;, Hawkeyes, results, arm, tools, intangibles, Georgia&amp;, athleticism, history, Heisman Trophy, value, NFL, NFL draft" /><meta name="sailthru.title" content="Pick-Six: Intriguing Players Available on Day 2 of NFL Draft" /><meta name="sailthru.description" content="Six wide receivers were taken in the first round of the NFL draft and another half dozen could go on Day 2, when rounds two and three are completed." /><meta name="sailthru.tags" content="Utah, Boise State&amp;, McKinney, Ezra Cleveland, DE, Dobbins, running backs, Alabama, Georgia, Washington, Oklahoma, Kansas City, Wisconsin, NFL Draft Coverage NFL, board, Normal NFL, board, board, rivals, WR, Penn State&amp;, Alabama Alabama, Group of Five, LSU&amp;, SEC, Ohio State, Utah State, A.J., Big Ten, Green Bay Packers, RB, NCAA, round, draft, Kind of Looked, round, draft, season, game, round, run, catches, competition, season, game, seasons, pick, running back, safeties, dozen, running backs, none, plenty, receivers, Changes, Bengals Take, defensive back, five, Notre Dame&amp;#, combine, talent, champion, board, seasons, tackles, defensive end, tread, Thorpe Award, Colorado&amp;, Hawkeyes, results, arm, tools, intangibles, Georgia&amp;, athleticism, history, Heisman Trophy, value, NFL, NFL draft" /><meta name="sailthru.tags" content="Utah, Boise State&amp;, McKinney, Ezra Cleveland, DE, Dobbins, running backs, Alabama, Georgia, Washington, Oklahoma, Kansas City, Wisconsin, NFL Draft Coverage NFL, board, Normal NFL, board, board, rivals, WR, Penn State&amp;, Alabama Alabama, Group of Five, LSU&amp;, SEC, Ohio State, Utah State, A.J., Big Ten, Green Bay Packers, RB, NCAA, round, draft, Kind of Looked, round, draft, season, game, round, run, catches, competition, season, game, seasons, pick, running back, safeties, dozen, running backs, none, plenty, receivers, Changes, Bengals Take, defensive back, five, Notre Dame&amp;#, combine, talent, champion, board, seasons, tackles, defensive end, tread, Thorpe Award, Colorado&amp;, Hawkeyes, results, arm, tools, intangibles, Georgia&amp;, athleticism, history, Heisman Trophy, value, NFL, NFL draft" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2020-04-24T13:42:26+00:00" /><meta property="og:image" content="https://media.nbcconnecticut.com/2019/09/GettyImages-1209327617.jpg?resize=1200%2C675" /><meta name="twitter:image" content="https://media.nbcconnecticut.com/2019/09/GettyImages-1209327617.jpg?resize=1200%2C675" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcconnecticut.com\/news\/sports\/pick-six-intriguing-players-available-on-day-2-of-nfl-draft\/2260568\/","headline":"Pick-Six: Intriguing Players Available on Day 2 of NFL Draft","datePublished":"2020-04-24T13:42:26","dateModified":"2020-04-24T13:48:10","description":"Six wide receivers were taken in the first round of the NFL draft and another half dozen could go on Day 2, when rounds two and three are completed.","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"Utah, Boise State&, McKinney, Ezra Cleveland, DE, Dobbins, running backs, Alabama, Georgia, Washington, Oklahoma, Kansas City, Wisconsin, NFL Draft Coverage NFL, board, Normal NFL, board, board, rivals, WR, Penn State&, Alabama Alabama, Group of Five, LSU&, SEC, Ohio State, Utah State, A.J., Big Ten, Green Bay Packers, RB, NCAA, round, draft, Kind of Looked, round, draft, season, game, round, run, catches, competition, season, game, seasons, pick, running back, safeties, dozen, running backs, none, plenty, receivers, Changes, Bengals Take, defensive back, five, Notre Dame&#, combine, talent, champion, board, seasons, tackles, defensive end, tread, Thorpe Award, Colorado&, Hawkeyes, results, arm, tools, intangibles, Georgia&, athleticism, history, Heisman Trophy, value, NFL, NFL draft","publisher":{"@type":"Organization","name":"NBC Connecticut","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcconnecticut.com\/wp-content\/uploads\/2019\/09\/light_amp_wvit.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcconnecticut.com\/2019\/09\/GettyImages-1209327617.jpg?resize=1200%2C675","width":1200},"author":{"@type":"Person","name":"Ralph D. Russo"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">
			var dfpBuiltMappings = {}, dfpAdUnits = {};

			if (768 <= window.innerWidth) {									googletag.cmd.push(function() {
					dfpBuiltMappings["bottombanner"] = googletag.sizeMapping().addSize([768,1],[[970,90],[970,66],[970,250],[728,90]]).build();
dfpBuiltMappings["bottombox"] = googletag.sizeMapping().addSize([768,1],[[300,250]]).build();
dfpBuiltMappings["topbox"] = googletag.sizeMapping().addSize([768,1],[[300,250],[300,600]]).build();
dfpBuiltMappings["topbanner"] = googletag.sizeMapping().addSize([768,1],[[970,90],[970,66],[970,250],[728,90]]).build();
dfpBuiltMappings["logo"] = googletag.sizeMapping().addSize([768,1],[[88,31],[120,60]]).build();
dfpBuiltMappings["interstitial"] = googletag.sizeMapping().addSize([768,1],[[1,1]]).build();
					});
					var dfpAdDetails = {"topbox":{"path":"\/2620\/ots_web\/wvit\/news\/sports","sizes":[[300,250],[300,600]],"targeting":[]},"bottombox":{"path":"\/2620\/ots_web\/wvit\/news\/sports","sizes":[[300,250]],"targeting":[]},"logo":{"path":"\/2620\/ots_web\/wvit\/news\/sports","sizes":[[88,31],[120,60]],"targeting":[]},"topbanner":{"path":"\/2620\/ots_web\/wvit\/news\/sports","sizes":[[970,90],[970,66],[970,250],[728,90]],"targeting":[]},"interstitial":{"path":"\/2620\/ots_web\/wvit\/news\/sports","sizes":[[1,1]],"targeting":[]},"bottombanner":{"path":"\/2620\/ots_web\/wvit\/news\/sports","sizes":[[970,90],[970,66],[970,250],[728,90]],"targeting":[]}};
					var dfpSizeMapping = {"bottombanner":[[[768,1],[[970,90],[970,66],[970,250],[728,90]]]],"bottombox":[[[768,1],[[300,250]]]],"topbox":[[[768,1],[[300,250],[300,600]]]],"topbanner":[[[768,1],[[970,90],[970,66],[970,250],[728,90]]]],"logo":[[[768,1],[[88,31],[120,60]]]],"interstitial":[[[768,1],[[1,1]]]]};

					 } else { 									googletag.cmd.push(function() {
					dfpBuiltMappings["mobiletopbanner"] = googletag.sizeMapping().addSize([1,1],[[320,50]]).build();
dfpBuiltMappings["mobilemultibox"] = googletag.sizeMapping().addSize([1,1],[[300,250],[300,100],[320,50]]).build();
dfpBuiltMappings["mobilebottombanner"] = googletag.sizeMapping().addSize([1,1],[[320,50]]).build();
dfpBuiltMappings["mobilebackstage"] = googletag.sizeMapping().addSize([1,1],[[1,1]]).build();
					});
					var dfpAdDetails = {"mobilemultibox":{"path":"\/2620\/ots_mobile\/wvit_mobileweb\/news\/sports","sizes":[[300,250],[300,100],[320,50]],"targeting":[]},"mobilebackstage":{"path":"\/2620\/ots_mobile\/wvit_mobileweb\/news\/sports","sizes":[[1,1]],"targeting":[]},"mobilebottombanner":{"path":"\/2620\/ots_mobile\/wvit_mobileweb\/news\/sports","sizes":[[320,50]],"targeting":[]},"mobiletopbanner":{"path":"\/2620\/ots_mobile\/wvit_mobileweb\/news\/sports","sizes":[[320,50]],"targeting":[]}};
					var dfpSizeMapping = {"mobiletopbanner":[[[1,1],[[320,50]]]],"mobilemultibox":[[[1,1],[[300,250],[300,100],[320,50]]]],"mobilebottombanner":[[[1,1],[[320,50]]]],"mobilebackstage":[[[1,1],[[1,1]]]]};

													}					googletag.cmd.push(function() {
					googletag.pubads().enableAsyncRendering();
googletag.pubads().collapseEmptyDivs();
					googletag.pubads().addEventListener('slotRenderEnded', function(event) {
						if (false === event.isEmpty) {
							var slotElementId = event.slot.getSlotElementId();
							if (0 <= slotElementId.indexOf('topbanner')) {
								document.body.classList.add("topbanner");
							}
						}
					});
						googletag.pubads().setTargeting("zipcode", localStorage.getItem("zipCode") || nbc.zipCode );

	var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
	googletag.pubads().setTargeting("gpt1", isMobile ? "ots_mobile" : "ots_web");
	googletag.pubads().setTargeting("platform", isMobile ? "mobile" : "desktop");
			googletag.pubads().setTargeting("source", "www.nbcconnecticut.com");
				googletag.pubads().setTargeting("pageid", "10072260568");
				googletag.pubads().setTargeting("pageid2", "10015077036");
				googletag.pubads().setTargeting("sect", "news");
				googletag.pubads().setTargeting("sub", "sports");
				googletag.pubads().setTargeting("call", "WVIT");
				googletag.pubads().setTargeting("region", "hartford");
				googletag.pubads().setTargeting("stationtype", "nbc");
				googletag.pubads().setTargeting("tags", "news,sports,nfl,nfl-draft");
				googletag.pubads().setTargeting("gpt2", "WVIT");
				googletag.pubads().setTargeting("station", "ots");
				googletag.pubads().setTargeting("sponsor", "");
				googletag.pubads().setTargeting("excl_cat", "news,sports");
		
					if ( typeof AdLayersAPI === 'undefined' || ! AdLayersAPI.isDebug() ) {
						googletag.enableServices();
					}
				});
								var dfpAdLayer = {"post_id":"2153386","title":"Article Ad Layer"};

			</script>
			<link rel="amphtml" href="https://www.nbcconnecticut.com/news/sports/pick-six-intriguing-players-available-on-day-2-of-nfl-draft/2260568/?amp"><link rel="icon" href="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=270%2C270" />
</head>

<body class="post-template-default single single-post postid-2260568 single-format-standard station-nbc wvit has-featured-image continuing visible-alert-bar short-hero">
	<div id="fb-root"></div>
		<script
			async
			defer
			crossorigin="anonymous"
			src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=81242742459&autoLogAppEvents=1"></script>
	<div class="leaderboard_ad">
	<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script></div>
<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
	<div class="alert-bar full-width continuing">
	<div class="alert-bar__content">
		<h4 class="alert-bar__heading">
			Continuing Coverage		</h4>
		<span class="alert-bar__title">
			<a href="https://www.nbcconnecticut.com/news/coronavirus/live-at-4pm-governor-lamont-to-provide-update-on-connecticuts-coronavirus-response/2259947/">
				<span
					class="alert-bar__inner"
					data-react-component="NBCTruncate"
					data-maxlines="1"
					data-maxlinesmobile="2"
					data-readmore=""
					data-text="Connecticut Reopening Likely Later Than May 20; Could Be Staggered Across Months"
					data-ellipsis="true">
					Connecticut Reopening Likely Later Than May 20; Could Be Staggered Across Months				</span>
			</a>
	</div>
</div>
	<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcconnecticut.com/">
						<img
							src="https://media.nbcconnecticut.com/2019/09/CT_On_Dark@3x-3.png?fit=186%2C120"
							alt="NBC Connecticut"
						/>
					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcconnecticut.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-header-container"><nav id="primary-menu" class="menu"><a class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/local/">Local</a></li>
<a class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Video</a></li>
<a class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a class=" menu-item menu-item-type-custom menu-item-object-custom" href="/traffic/">Traffic</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcconnecticut.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a href="/news/coronavirus/" class="site-header__trending-nav-item">Coronavirus Pandemic</a>
					<a href="/community/kids-connection/" class="site-header__trending-nav-item">Kids Connection</a>
					<a href="https://www.nbcconnecticut.com/news/coronavirus/ct-resource-connection-community-services-for-you-and-your-family-during-the-coronavirus-pandemic/2249264/" class="site-header__trending-nav-item">CT Resource Connection</a>
					<a href="/newsletters/" class="site-header__trending-nav-item">CT Coronavirus Newsletter</a>
					<a href="https://www.nbcconnecticut.com/news/local/how-many-in-tri-state-have-tested-positive-for-coronavirus-here-are-latest-cases-by-the-numbers/2234982/" class="site-header__trending-nav-item">Tracking Tri-State Infections</a>
					<a href="/entertainment/ct-live/" class="site-header__trending-nav-item">CT Live</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather with-divider"
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="6096">
	</div>
			<a
			href="https://www.nbcconnecticut.com/weather/school-closings/"
			class="site-header__alerts-item site-header__alerts-item--general"
		>
			10 School Closings		</a>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
	</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2260568" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcconnecticut.com/tag/nfl-draft/">NFL draft</a>						</div>
</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Pick-Six: Intriguing Players Available on Day 2 of NFL Draft	</h1>
			<h2 class="article-subtitle">
			The best safeties are still available because none were taken on Day 1		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By Ralph D. Russo							<span class="meta-dot">&bull;</span>
					
							<span class="time-wrap">
				<time class="entry-date published" datetime="2020-04-24T17:42:26-04:00">Published 27 mins ago</time>					<span class="meta-dot">&bull;</span>
				<time class="entry-date updated" datetime="2020-04-24T13:48:10-04:00">Updated 21 mins ago</time>			</span>
			</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F&#038;Pick-Six%3A%20Intriguing%20Players%20Available%20on%20Day%202%20of%20NFL%20Draft?_osource=db_npd_nbc_wvit_fb_shr" data-service="facebook">
			<i class="fab fa-facebook-f"></i>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Pick-Six%3A%20Intriguing%20Players%20Available%20on%20Day%202%20of%20NFL%20Draft&#038;url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F?_osource=db_npd_nbc_wvit_twt_shr" data-service="twitter">
			<i class="fab fa-twitter"></i>
		</a>
	
			<a href="mailto:?body=Pick-Six%3A%20Intriguing%20Players%20Available%20on%20Day%202%20of%20NFL%20Draft%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F?_osource=db_npd_nbc_wvit_eml_shr" data-service="email">
			<i class="fas fa-envelope"></i>
		</a>
	
	</div>
</div>
	</div>
	</div>
	<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<figure class="article-featured-media">
	<img
		src="https://media.nbcconnecticut.com/2019/09/GettyImages-1209327617.jpg?resize=850%2C478"
		alt="Wide receiver Michael Pittman Jr."
	/>
			<figcaption>
							<cite>Joe Robbins/Getty Images</cite>
			
												<div
						class="caption"
						data-react-component="NBCTruncate"
						data-maxlines="2"
						data-maxlinesmobile="4"
						data-readmore="Read more"
						data-text="Wide receiver Michael Pittman Jr. of USC runs the 40-yard dash during the NFL Scouting Combine at Lucas Oil Stadium on Feb. 27, 2020 in Indianapolis, Indiana."
						data-ellipsis="false">
					</div>
									</figcaption>
	</figure>
				<div class="article-content rich-text">

					
<p>Six wide receivers were taken in the first round of the NFL draft and another half dozen could go on Day 2, when rounds two and three are completed.</p>

<p>The best safeties are still available because none were taken on Day 1. And there are plenty of good running backs left after only one went off the board in the first round.</p>

<p>The six most intriguing players available heading into Day 2 of the NFL draft.</p>
<div class="recirc-module">
	<h3 class="recirc__heading">NFL Draft Coverage</h3>
	<p class="recirc__subheading"></p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a href="https://www.nbcconnecticut.com/news/sports/one-constant-in-this-unique-draft-joe-burrow-at-the-top/2260234/">
							<img class="post__image" src="https://media.nbcconnecticut.com/2019/09/NFL-Draft-From-Home.jpg?crop=0px%2C63px%2C1317px%2C741px&#038;resize=850%2C478" alt="" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a class="post__tag" href="https://www.nbcconnecticut.com/tag/nfl-draft/">NFL draft</a>
																			<span class="post__date post__date--has-category">
								17 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a class="post__title--link" href="https://www.nbcconnecticut.com/news/sports/one-constant-in-this-unique-draft-joe-burrow-at-the-top/2260234/">
								<span data-ellipsis="true" data-text="For All the Changes, NFL Draft Kind of Looked, Well, Normal" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									For All the Changes, NFL Draft Kind of Looked, Well, Normal								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a href="https://www.nbcconnecticut.com/news/sports/nfl-draft-bengals-take-qb-joe-burrow-with-top-pick/2260228/">
							<img class="post__image" src="https://media.nbcconnecticut.com/2019/09/AP_20115018215375.jpg?resize=850%2C478" alt="" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a class="post__tag" href="https://www.nbcconnecticut.com/tag/nfl-draft/">NFL draft</a>
																			<span class="post__date post__date--has-category">
								18 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a class="post__title--link" href="https://www.nbcconnecticut.com/news/sports/nfl-draft-bengals-take-qb-joe-burrow-with-top-pick/2260228/">
								<span data-ellipsis="true" data-text="NFL Draft: Bengals Take QB Joe Burrow With Top Pick" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									NFL Draft: Bengals Take QB Joe Burrow With Top Pick								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<h2 class="wp-block-nbc-section-heading">Michael Pittman, WR, USC</h2>

<p>Pittman is big and physical at 6-foot-4 and 224 pounds. And he torched a talented Utah secondary last season for 10 catches for 232 yards with a backup quarterback in the game. Expect another run on receivers with Pittman, Clemson's Tee Higgins, Colorado's Laviska Shenault Jr., Baylor's Denzel Mims and Notre Dame's Chase Claypool still on the board.</p>

<h2 class="wp-block-nbc-section-heading">Xavier McKinney, S, Alabama</h2>

<p>Alabama had four players taken in the first round, second only to national champion LSU's five. But the two players generally regarded as the best safeties are from the SEC rivals and still available. McKinney is a rangy and versatile playmaker. LSU's Grant Delpit was the Thorpe Award winner as the nation's best defensive back last year, though he was much better in 2018 than 2019. Figure both could be gone by the third round.</p>

<h2 class="wp-block-nbc-section-heading">Josh Jones, OT, Houston</h2>

<p>Jones is an athletic four-year starter with first-round talent, but couldn't crack into the first round where six tackles were taken. Boise State's Ezra Cleveland is another athletic Group of Five tackle expected to be be off the board pretty early on Friday.</p>

<h2 class="wp-block-nbc-section-heading">A.J. Epenesa, DE, Iowa</h2>

<p>Epenesa was a productive former five-star recruit for the Hawkeyes, but his combine was just OK. That nudged him into Day 2 along with another Big Ten defensive end. Penn State's Yetur Gross-Matos has more athleticism than Epenesa, but his game is not as refined. Still, both should provide good second-round value.</p>

<h2 class="wp-block-nbc-section-heading">Jonathan Taylor, RB, Wisconsin</h2>

<p>The only running back taken in the first round was Clyde Edwards-Helaire from LSU on the last pick to Kansas City. Taylor was one of the most productive running backs in NCAA history with three seasons of more than 1,900 yards. Will he be the next back off the board? Or maybe Georgia's D'Andre Swift, who has far less tread on his tires. Or J.K. Dobbins, who had three 1,000-yard seasons for Ohio State.</p>

<h2 class="wp-block-nbc-section-heading">Two Jakes</h2>

<p>Four quarterbacks went in the first round, with Jordan Love from Utah State getting scooped up at No. 26 by the Green Bay Packers. Who will be the next quarterback taken?</p>

<p>It might be another competition between Jacob Eason and Jake Fromm. Eason was the starter at Georgia in 2017 before getting hurt and being replaced by Fromm. Eason transferred to Washington the next season.</p>

<p>Eason is a big guy with a huge arm, but up-and-down results. Fromm has all the intangibles but not quite the physical tools of Eason.</p>

<p>Or what about Jalen Hurts? He transferred from Alabama to Oklahoma and became a Heisman Trophy finalist last year.</p>

<p></p>

									</div>
							<div class="article-copyright">Copyright AP - Associated Press</div>
	
	<div class="article-footer">
		<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcconnecticut.com/tag/nfl-draft/">NFL draft</a><a class="article-tags__tag" href="https://www.nbcconnecticut.com/tag/nfl/">NFL</a></div>
		<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F&#038;Pick-Six%3A%20Intriguing%20Players%20Available%20on%20Day%202%20of%20NFL%20Draft?_osource=db_npd_nbc_wvit_fb_shr" data-service="facebook">
			<i class="fab fa-facebook-f"></i>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Pick-Six%3A%20Intriguing%20Players%20Available%20on%20Day%202%20of%20NFL%20Draft&#038;url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F?_osource=db_npd_nbc_wvit_twt_shr" data-service="twitter">
			<i class="fab fa-twitter"></i>
		</a>
	
			<a href="mailto:?body=Pick-Six%3A%20Intriguing%20Players%20Available%20on%20Day%202%20of%20NFL%20Draft%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcconnecticut.com%2Fnews%2Fsports%2Fpick-six-intriguing-players-available-on-day-2-of-nfl-draft%2F2260568%2F?_osource=db_npd_nbc_wvit_eml_shr" data-service="email">
			<i class="fas fa-envelope"></i>
		</a>
	
			<a href="#" data-service="comments">
			<i class="fas fa-comment-alt"></i>

			<div class="share-buttons__comment-count">
				<div class="fb-comments-count" data-href="https://www.nbcconnecticut.com/news/sports/pick-six-intriguing-players-available-on-day-2-of-nfl-draft/2260568/">0</div>
			</div>
		</a>
	</div>
	</div>
				<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'text'
			});
		};
	</script>
	<div id="taboola-below-article-text-links"></div>
		<script type="text/javascript">
		/** scroll cookie for scroll.com **/
			if (document.cookie.indexOf("scroll0=") < 0) {
				window._taboola = window._taboola || [];
				_taboola.push({
					mode: 'hybrid-text-links-a',
					container: 'taboola-below-article-text-links',
					placement: 'Below Article Text Links',
					target_type: 'text'
				});
			};
		</script>
				</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_214" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_214', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h2>Weather Forecast</h2><div class="widget_location">Hartford, CT</div>
	<a class="weather-module__conditions" href="https://www.nbcconnecticut.com/weather/">
		<div data-react-component="IframeConditions" data-location="6096"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_550" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_550', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_184" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_184', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-1770517932" class="module-civicScience"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_258" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_258', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_902" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_902', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_892" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_892', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

							
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcconnecticut.com/" class="site-footer__logo">
					<img
						src="https://media.nbcconnecticut.com/2019/09/On_Light@3x-1.png?fit=189%2C120"
						alt="NBC Connecticut"
					/>
				</a>
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/NBCConnecticut" target="_blank">
							<span class="screen-reader-text">Facebook</span>
							<i class="fab fa-facebook-f"></i>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcconnecticut" target="_blank">
							<span class="screen-reader-text">Twitter</span>
							<i class="fab fa-twitter"></i>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcconnecticut" target="_blank">
							<span class="screen-reader-text">Instagram</span>
							<i class="fab fa-instagram"></i>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2175766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2175766"><a href="/investigations/submit-tip/">Submit Tips for Investigations</a></li>
<li id="menu-item-2175709" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2175709"><a href="https://www.nbcconnecticut.com/newsletters/">Newsletters</a></li>
<li id="menu-item-2175710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2175710"><a href="https://www.nbcconnecticut.com/contact-us/">Contact Us</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1942066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942066"><a href="https://publicfiles.fcc.gov/tv-profile/wvit/">WVIT Public Inspection File</a></li>
<li id="menu-item-1942067" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942067"><a href="http://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_Connecticut/">Privacy policy &#8211; New</a></li>
<li id="menu-item-2154770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2154770"><a href="http://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_Connecticut/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1942081" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1942081"><a href="https://www.nbcconnecticut.com/wvit-employment-information/">WVIT Employment Information</a></li>
<li id="menu-item-1942080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1942080"><a href="https://www.nbcconnecticut.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-1942068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942068"><a href="https://info.evidon.com/pub_info/209?v=1&#038;nt=0&#038;nw=false/">Ad Choices</a></li>
<li id="menu-item-1942069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942069"><a href="mailto:WVITViewerMail.Advertising@nbcuni.com?subject=Advertise%20with%20Us%20HP/">Advertise with us</a></li>
<li id="menu-item-1942079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1942079"><a href="https://www.nbcconnecticut.com/send-feedback/">Send Feedback</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2020 NBC Universal Inc. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type='text/javascript'>
	(function() {
		function CreateEvent(type, data) {
			var event;

			if ('undefined' === typeof data) {
				data = {};
			}

			try {
				event = new CustomEvent(type, { detail: data });
			} catch (err) {
				event = document.createEvent('CustomEvent');
				event.initCustomEvent(type, true, true, data);
			}

			return event;
		}

		var pdk6Url = "https://www.nbcconnecticut.com/wp-content/themes/nbc-station/static/video/pdk6/player.6.1.3.js";		var pdkScript = pdk6Url;
		var win7ie = navigator.userAgent.indexOf('Windows NT 6.1') > -1 && (navigator.userAgent.indexOf('Trident') > -1 || navigator.userAgent.indexOf('MSIE') > -1);

		pdkScript = win7ie ?
			"https://www.nbcconnecticut.com/wp-content/themes/nbc-station/static/video/pdk5/tpPdk.js"			: pdk6Url;

		if (pdkScript) {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.src = pdkScript;
			s.onload = function() {
				window.dispatchEvent(
					CreateEvent('nbc:pdkLoaded')
				);
			};
			document.body.appendChild(s);
		}
	})();
	</script>
	<link rel="stylesheet" href="https://www.nbcconnecticut.com/wp-content/themes/nbc-station/static/video/pdk6/player_smooth.css?v=102319" type="text/css" />		<script type="text/javascript">
		(function() {
						var _sf_async_config      = window._sf_async_config = (window._sf_async_config || {});
			_sf_async_config.domain   = "nbcconnecticut.com";
			_sf_async_config.uid      = 15527;
			_sf_async_config.sections = "sports";
			_sf_async_config.authors  = "Ralph D. Russo";
			_sf_async_config.title    = "Pick-Six: Intriguing Players Available on Day 2 of NFL Draft";

			function loadChartbeat() {
				var e = document.createElement('script');
				var n = document.getElementsByTagName('script')[0];
				e.type = 'text/javascript';
				e.async = true;
				e.src = '//static.chartbeat.com/js/chartbeat.js';
				n.parentNode.insertBefore(e, n);
			}
			loadChartbeat();
		})();
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><i class="fas fa-chevron-left"></i> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcconnecticut.com/news/sports/pick-six-intriguing-players-available-on-day-2-of-nfl-draft/2260568/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><i class="fas fa-times"></i> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcconnecticut.com/">
					<img
						src="https://media.nbcconnecticut.com/2019/09/On_Light@3x-1.png?fit=189%2C120"
						alt="NBC Connecticut"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcconnecticut.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a class="flyout-nav__menu-item child-item" href="https://www.nbcconnecticut.com/news/coronavirus/ct-resource-connection-community-services-for-you-and-your-family-during-the-coronavirus-pandemic/2249264/">
					CT Resource Connection				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. &amp; World				</a>
							<a class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a class="flyout-nav__menu-item parent-item" href="https://www.nbcconnecticut.com/videos/">
					Video				</a>
							<a class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a class="flyout-nav__menu-item child-item" href="/weather/school-closings/">
					School Closings				</a>
							<a class="flyout-nav__menu-item child-item" href="https://my.textcaster.com/asa/1775">
					Sign Up For School Closing Text Alerts				</a>
							<a class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a class="flyout-nav__menu-item parent-item" href="/investigations/nbc-ct-responds/">
					NBC CT Responds				</a>
							<a class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a class="flyout-nav__menu-item child-item" href="/entertainment/entertainment-news/">
					Entertainment News				</a>
							<a class="flyout-nav__menu-item child-item" href="/entertainment/ct-live/">
					CT Live				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a class="flyout-nav__menu-item child-item" href="/news/sports/dog-house/">
					Dog House				</a>
							<a class="flyout-nav__menu-item parent-item" href="/community/">
					Community				</a>
							<a class="flyout-nav__menu-item parent-item" href="/news/health/connecttohealthier/">
					Connect To Healthier				</a>
							<a class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a Consumer Complaint				</a>
							<a class="flyout-nav__menu-item child-item" href="https://www.nbcconnecticut.com/ugc/">
					Submit Photos and Video				</a>
							<a class="flyout-nav__menu-item child-item" href="/on-air/contests/">
					Contests				</a>
							<a class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a class="flyout-nav__menu-item child-item" href="https://www.nbcconnecticut.com/newsletters/">
					Newsletters				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook">
					<a href="http://www.facebook.com/NBCConnecticut" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<i class="fab fa-facebook-f"></i>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter">
					<a href="https://twitter.com/nbcconnecticut" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<i class="fab fa-twitter"></i>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram">
					<a href="https://instagram.com/nbcconnecticut" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<i class="fab fa-instagram"></i>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button"
			href="/contact-us"
	>
	Contact Us</a>
<script type='text/javascript' src='https://www.nbcconnecticut.com/_static/??-eJx9i0sOwjAMBS9E+4pQ+SwQR0EliajTxI6wLa5PFl2zmsXM4NuGIGyJDdWHVvxNrMjJ2hI2PIkDXk4loq1iwjvGSjxmPaDvPSkeU58UkdTgn/LXryKb7sWj3o/z9TLNp+l8yz/WNzM6'></script>
<script>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/api-fetch.min.js?ver=3.6.4'></script>
<script>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</script>
<script type='text/javascript' src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/common.7128ab1aef806dd529d1.chunk.min.js?m=1587493292g'></script>
<script>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</script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/nonamp.0f6dc386d55514a93a16.bundle.min.js?ver=1.0.2'></script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.5a6267eee8727c2e0f5d.bundle.min.js?ver=1.0.2'></script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/global.c6f41e21c7fe75f9b2f3.bundle.min.js?ver=1.0.2'></script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/article.d1f7ad391a7ef757cae4.bundle.min.js?ver=1.0.2'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0'></script>
<script>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.faa6254630c6f634397a.bundle.min.js?ver=1.0.2'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.3.2'></script>
<script defer src='https://js-sec.indexww.com/ht/p/186439-109265750698089.js?ver=1.0.2'></script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.15'></script>
<script>
window.lodash = _.noConflict();
</script>
<script type='text/javascript' src='https://www.nbcconnecticut.com/wp-includes/js/wp-embed.min.js?m=1576711033g'></script>
<script src='https://www.civicscience.com/widget/jspoll/?elt=civsci-1770517932&#038;tgtid=1f68dd5f-a75a-70f4-2df8-00eacbc47222&#038;ver=1.0.0'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202017.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'165596134',post:'2260568',tz:'-4',srv:'www.nbcconnecticut.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596134', '2260568' ]);
</script>

</body>
</html>
