<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Wintry Mix Creates Icy Conditions for Northwest CT &#8211; NBC Connecticut</title>
<link rel='dns-prefetch' href='//assets.adobedtm.com' />
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC Connecticut &raquo; Feed" href="https://www.nbcconnecticut.com/?rss=y" />
<link rel='stylesheet' id='all-css-0' href='https://www.nbcconnecticut.com/_static/??-eJylz01ORCEQBOALOdDQ/eCxMC48CTSNEvmZCMbrO8Z4AMd1VX1J6c/rhefYMrber9Jl6ZH4snbcdQ7NrX4n6aO2rHktzbP3OVQAjwJcrGAO4YAgZ1a9DnXrPOg/mi9tptgUQQFyBdkdBAnJBaG7zfi+KzdRYHIUawxFG6AwpJP+jT7/TJRjQ+RSKR4jZ4+IZO62U5v8tlTJ7kjWGnZGSkTw5+F/zaf+aBwR3O648AWjWpgZ' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.nbcconnecticut.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.nbcconnecticut.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<script async src='https://assets.adobedtm.com/a2ef59fba8e9/3ba8c6b033ff/launch-6a742ce4ddf5.min.js?ver=1.0.2' id='adobe-launch-js'></script>
<link rel="https://api.w.org/" href="https://www.nbcconnecticut.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcconnecticut.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcconnecticut.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.8" />
<link rel="canonical" href="https://www.nbcconnecticut.com/weather-news/stories/wintry-mix-creates-icy-conditions-for-northwest-ct/2710623/" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcconnecticut.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcconnecticut.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcconnecticut.com/2019/09/OTT-CT.png?resize=1440%2C415&quality=85&strip=all'); }
</style>
<link rel="preload" href="https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin /><script>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</script><meta property="og:site_name" content="NBC Connecticut" /><meta name="google-site-verification" content="9DR-KZ3Q4cScEQmsx4MezWlQQHm13mICp8H7ZDGvvug" /><meta property="fb:app_id" content="81242742459" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcconnecticut" /><meta name="twitter:creator" content="@nbcconnecticut" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="http://www.facebook.com/NBCConnecticut" /><meta name="description" content="Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday. The icy conditions left icicles,..." /><meta property="og:description" content="Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday. The icy conditions left icicles, frozen branches and snow-covered trees in and around Norfolk. Drivers brought out their best tools to clear car windshields and windows after the snowy mix created freezing conditions. “It’s just tough when it…" /><meta name="twitter:description" content="Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday. The icy conditions left icicles, frozen branches and snow-covered trees in and around Norfolk. Drivers brought out their best tools to clear car windshields and windows after the snowy mix created freezing conditions. “It’s just tough when it…" /><meta property="og:title" content="Wintry Mix Creates Icy Conditions for Northwest CT" /><meta name="twitter:title" content="Wintry Mix Creates Icy Conditions for Northwest CT" /><meta name="keywords" content="canaan, freezing rain, Norfolk, sleet, snow, Wintry Mix" /><meta property="og:url" content="https://www.nbcconnecticut.com/weather-news/stories/wintry-mix-creates-icy-conditions-for-northwest-ct/2710623/" /><meta name="twitter:url" content="https://www.nbcconnecticut.com/weather-news/stories/wintry-mix-creates-icy-conditions-for-northwest-ct/2710623/" /><meta name="sailthru.title" content="Wintry Mix Creates Icy Conditions for Northwest CT" /><meta name="sailthru.description" content="Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday. The icy conditions left icicles,..." /><meta name="sailthru.tags" content="canaan, freezing rain, Norfolk, sleet, snow, Wintry Mix" /><meta name="sailthru.tags" content="canaan, freezing rain, Norfolk, sleet, snow, Wintry Mix" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2022-02-04T22:43:08+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcconnecticut.com/2022/02/SNOW-PICTURES-STILL-1.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="twitter:image" content="https://media.nbcconnecticut.com/2022/02/SNOW-PICTURES-STILL-1.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcconnecticut.com\/weather-news\/stories\/wintry-mix-creates-icy-conditions-for-northwest-ct\/2710623\/","headline":"Wintry Mix Creates Icy Conditions for Northwest CT","datePublished":"2022-02-04T22:43:08","dateModified":"2022-02-04T23:26:48","description":"Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday. The icy conditions left icicles,\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"canaan, freezing rain, Norfolk, sleet, snow, Wintry Mix","publisher":{"@type":"Organization","name":"NBC Connecticut","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcconnecticut.com\/wp-content\/uploads\/2019\/09\/light_amp_wvit.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcconnecticut.com\/2022\/02\/SNOW-PICTURES-STILL-1.jpg?quality=85&strip=all&resize=1200%2C675","width":1200},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.nbcconnecticut.com\/weather-news\/stories\/wintry-mix-creates-icy-conditions-for-northwest-ct\/2710623\/","description":"Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday. The icy conditions left icicles, frozen branches and snow-covered trees in and around Norfolk. Drivers brought out their best tools to clear car windshields and windows after the snowy mix created freezing conditions. &#8220;It&#8217;s just tough when it&#8230;","duration":"PT02M48S","name":"Wintry Mix Creates Icy Conditions for Northwest CT","thumbnailUrl":"https:\/\/media.nbcconnecticut.com\/2022\/02\/SNOW-PICTURES-STILL-1.jpg?quality=85&strip=all&resize=1200%2C675","uploadDate":"2022-02-04T22:43:08"},"author":{"@type":"Person","name":"Dominique Moody"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcconnecticut.com/weather-news/stories/wintry-mix-creates-icy-conditions-for-northwest-ct/2710623/?amp"><link rel="icon" href="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcconnecticut.com/2019/09/cropped-NBC_Connecticut.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-2710623 single-format-standard station-nbc wvit has-featured-image short-hero">
	<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcconnecticut.com/">
						<img src="https://media.nbcconnecticut.com/2021/04/CT.png?fit=216%2C120&#038;quality=85&#038;strip=all&#038;w=72&#038;h=40" srcset="https://media.nbcconnecticut.com/2021/04/CT.png?fit=216%2C120&amp;quality=85&amp;strip=all&amp;w=72&amp;h=40 1x, https://media.nbcconnecticut.com/2021/04/CT.png?fit=216%2C120&amp;quality=85&amp;strip=all&amp;w=144&amp;h=80 2x, https://media.nbcconnecticut.com/2021/04/CT.png?fit=216%2C120&amp;quality=85&amp;strip=all&amp;w=216&amp;h=120 3x" alt="NBC Connecticut" height="40" width="72" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcconnecticut.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-header-container"><nav id="primary-menu" class="menu"><a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" href="/news/local/">Local</a></li>
<a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Video" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/videos/">Video</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a data-lid="Traffic" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/traffic/">Traffic</a></li>
<a data-lid="NBC CT Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcconnecticut.com/newsletters/">NBC CT Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcconnecticut.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="The Torch: Olympics Updates" data-lpos="trending-stories-module" href="/news/sports/beijing-winter-olympics/the-torch/" class="site-header__trending-nav-item">The Torch: Olympics Updates</a>
					<a data-lid="First Alert Weather Blog" data-lpos="trending-stories-module" href="https://www.nbcconnecticut.com/weather-news/stories/firstalertforecast/81047/" class="site-header__trending-nav-item">First Alert Weather Blog</a>
					<a data-lid="Hidden in Plain Sight" data-lpos="trending-stories-module" href="/investigations/hidden-in-plain-sight/" class="site-header__trending-nav-item">Hidden in Plain Sight</a>
					<a data-lid="NBC CT&#039;s The Connection" data-lpos="trending-stories-module" href="/the-connection/" class="site-header__trending-nav-item">NBC CT&#039;s The Connection</a>
					<a data-lid="CT Live" data-lpos="trending-stories-module" href="/entertainment/ct-live/" class="site-header__trending-nav-item">CT Live</a>
					<a data-lid="Winter Olympics Newsletter" data-lpos="trending-stories-module" href="https://www.nbcconnecticut.com/news/sports/beijing-winter-olympics/?_osource=ed_npd_nbc_nat_ot_newltrtrending" class="site-header__trending-nav-item">Winter Olympics Newsletter</a>
					<a data-lid="Face the Facts" data-lpos="trending-stories-module" href="/news/politics/face-the-facts/" class="site-header__trending-nav-item">Face the Facts</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather with-divider"
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="6096">
	</div>
			<a
			href="https://www.nbcconnecticut.com/weather/school-closings/"
			class="site-header__alerts-item site-header__alerts-item--general"
		>
			19 School Closings		</a>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2710623" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcconnecticut.com/tag/wintry-mix/">Wintry Mix</a>						</div>
	</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Wintry Mix Creates Icy Conditions for Northwest CT	</h1>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By <a href="https://www.nbcconnecticut.com?s=Author%3A%20%22Dominique%20Moody%22">Dominique Moody</a>							<span class="meta-dot">&bull;</span>
					
									<span class="time-wrap">
					<time class="entry-date published" datetime="2022-02-05T03:43:08-05:00">Published 1 hour ago</time>						<span class="meta-dot">&bull;</span>
					<time class="entry-date updated" datetime="2022-02-04T23:26:48-05:00">Updated 40 mins ago</time>				</span>
						</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F&#038;Wintry%20Mix%20Creates%20Icy%20Conditions%20for%20Northwest%20CT?_osource=db_npd_nbc_wvit_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Wintry%20Mix%20Creates%20Icy%20Conditions%20for%20Northwest%20CT&#038;url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F?_osource=db_npd_nbc_wvit_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Wintry%20Mix%20Creates%20Icy%20Conditions%20for%20Northwest%20CT%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F?_osource=db_npd_nbc_wvit_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<div class="video-flyout" data-component="videoFlyout">
	<figure class="article-featured-media video-lead">
		<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:1576,&quot;nbc_primary_tag_id&quot;:292744,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS_-_WVIT\/663\/167\/14658309973.dfxp&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS_-_WVIT\/663\/167\/14658309973-1080pnbcstations.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;nxeza6jQhQ0C&quot;,&quot;mpx_download_pid_high&quot;:&quot;XC8uim5KwBFB&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;AEHi9N_j9d55&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcconnecticut.com\/2022\/02\/14658309973-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;vMBgDKP1cYTY&quot;,&quot;pid_streaming_web_medium&quot;:&quot;sR3ENusdCy1u&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;WVIT&quot;,&quot;video_captions&quot;:&quot;Array&quot;,&quot;video_id&quot;:&quot;2000001603960_129&quot;,&quot;video_length&quot;:&quot;168035&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;ZMNFQZBoG7nj&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;Vt1wbVtvxB82&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;AEHi9N_j9d55&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_2000001603960&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="Wintry Mix Creates Icy Conditions for Northwest CT"
	data-vidcid="1:7:2710643"
	data-vidurl="https://www.nbcconnecticut.com/weather-news/wintry-mix-creates-icy-conditions-for-northwest-ct/2710643/"
			data-islead="true"
		data-catnames="{&quot;195200&quot;:&quot;News&quot;,&quot;418&quot;:&quot;Local&quot;,&quot;196398&quot;:&quot;Top Video&quot;,&quot;1576&quot;:&quot;Weather&quot;}"
	data-tagnames="{&quot;322500&quot;:&quot;northwest Connecticut&quot;,&quot;292744&quot;:&quot;Wintry Mix&quot;}"
	data-customdata="{&quot;ContentPartner&quot;:&quot;None&quot;,&quot;Source&quot;:&quot;WEBFM&quot;,&quot;SyndicationAllowed&quot;:&quot;true&quot;,&quot;mSNVideoCategories&quot;:&quot;MSN Video v4 Connector-most watched news&quot;,&quot;mSNVideoContentSupplierID&quot;:&quot;NBC_Local&quot;,&quot;mSNVideoCountry&quot;:&quot;us&quot;,&quot;subtitle&quot;:&quot;nosubtitle&quot;,&quot;uploadedByTeam&quot;:&quot;1&quot;,&quot;youtubeChannel&quot;:&quot;None&quot;}"
			data-autoplay="true"
				data-cplay="true"
	></div>
			<figcaption>
									<cite>NBC Universal, Inc.</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="&lt;p&gt;Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday.&lt;/p&gt;
"
							data-ellipsis="false">
						</div>
												</figcaption>
						<button class="video-flyout__dismiss"><span class="icon icon-times"></span></button>
			</figure>
</div>
				<div class="article-content rich-text">
					
					
<p>Sleet, freezing rain and a little bit of snow were some of the conditions the Northwest portion of the state received Friday.</p>

<p>The icy conditions left icicles, frozen branches and snow-covered trees in and around Norfolk.</p>

<p>Drivers brought out their best tools to clear car windshields and windows after the snowy mix created freezing conditions.</p>

<p>"It's just tough when it gets this cold and power goes out and then, you know, there's ice," said Carrere Tirrell, who lives in Norfolk and lost power due to the conditions. "Fortunately enough, we have a generator at our house, enough to run our furnace and some main appliances.”</p>

<p>Slush and rain forced drivers to slow down on the roads and created some slick spots around town.</p>

<p>Norfolk's Public Information Officer Jon Barbagallo tells NBC Connecticut the freezing weather and wintry mix caused problems for plows.</p>

<p>“It’s definitely worsened through the day, obviously the temperatures have dropped, through mid-day it was 30-31 degrees and rain," said Barbagallo. “Our town crews and the state crews are out but obviously as the temperatures plummet, it's going to be difficult to keep these road conditions clean.”</p>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	Download our local news and weather app for <a href="https://apps.apple.com/us/app/nbc-connecticut/id331803452">iOS</a> or <a href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcconnecticut.android&amp;hl=en_US">Android</a> <strong><strong><em>—</em></strong></strong> and choose the alerts you want.</blockquote>
</div>
</div>
<div class="recirc-module">
	<h3 class="recirc__heading">Local</h3>
	<p class="recirc__subheading"></p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="West Hartford-Area Residents Aim to Save Beloved Whale Conny at The Children&#039;s Museum" href="https://www.nbcconnecticut.com/news/local/west-hartford-area-residents-aim-to-save-beloved-whale-conny-at-the-childrens-museum/2710595/">
							<img class="post__image" srcset="https://media.nbcconnecticut.com/2022/02/conny-web.png?resize=200%2C113&amp;quality=85&amp;strip=all 200w, https://media.nbcconnecticut.com/2022/02/conny-web.png?resize=400%2C225&amp;quality=85&amp;strip=all 400w, https://media.nbcconnecticut.com/2022/02/conny-web.png?resize=600%2C338&amp;quality=85&amp;strip=all 600w, " src="https://media.nbcconnecticut.com/2022/02/conny-web.png?resize=600%2C338&#038;quality=85&#038;strip=all" alt="" sizes="200px" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="West Hartford" class="post__tag" href="https://www.nbcconnecticut.com/tag/west-hartford/">West Hartford</a>
																			<span class="post__date post__date--has-category">
								3 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="West Hartford-Area Residents Aim to Save Beloved Whale Conny at The Children&#039;s Museum" class="post__title--link" href="https://www.nbcconnecticut.com/news/local/west-hartford-area-residents-aim-to-save-beloved-whale-conny-at-the-childrens-museum/2710595/">
								West Hartford-Area Residents Aim to Save Beloved Whale Conny at The Children&#039;s Museum							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Waterbury, South Windsor Police Address Rise in Mental Health Crisis Calls" href="https://www.nbcconnecticut.com/news/local/waterbury-south-windsor-police-address-rise-in-mental-health-crisis-calls/2710591/">
							<img class="post__image" srcset="https://media.nbcconnecticut.com/2022/02/PD-MENTAL.png?resize=200%2C113&amp;quality=85&amp;strip=all 200w, https://media.nbcconnecticut.com/2022/02/PD-MENTAL.png?resize=400%2C225&amp;quality=85&amp;strip=all 400w, https://media.nbcconnecticut.com/2022/02/PD-MENTAL.png?resize=600%2C338&amp;quality=85&amp;strip=all 600w, " src="https://media.nbcconnecticut.com/2022/02/PD-MENTAL.png?resize=600%2C338&#038;quality=85&#038;strip=all" alt="" sizes="200px" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="mental health" class="post__tag" href="https://www.nbcconnecticut.com/tag/mental-health/">mental health</a>
																			<span class="post__date post__date--has-category">
								3 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Waterbury, South Windsor Police Address Rise in Mental Health Crisis Calls" class="post__title--link" href="https://www.nbcconnecticut.com/news/local/waterbury-south-windsor-police-address-rise-in-mental-health-crisis-calls/2710591/">
								Waterbury, South Windsor Police Address Rise in Mental Health Crisis Calls							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>
<div data-react-component="VideoPlayer" data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:12182,&quot;nbc_primary_tag_id&quot;:29147,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBCUniversal Media, LLC&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS_-_WVIT\/665\/118\/BOST_100000048333231.dfxp&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS_-_WVIT\/665\/118\/BOST_100000048333231__863439.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;XbnBJst4lDuv&quot;,&quot;mpx_download_pid_high&quot;:&quot;4fuqiou4eOtB&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;VEBXo72c3t4k&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcconnecticut.com\/2022\/02\/BOST_100000048333231.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;IyGO3jvP5PIw&quot;,&quot;pid_streaming_web_medium&quot;:&quot;VEBXo72c3t4k&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;WVIT&quot;,&quot;video_captions&quot;:&quot;&quot;,&quot;video_id&quot;:&quot;2000003651582_352&quot;,&quot;video_length&quot;:&quot;34668&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;SjOalR1Kxxp2&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;vrVLGtNukHWG&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;EFv__2frXbcj&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_2000003651582&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}" data-livestream="false" data-title="Overnight Forecast for February 5, 2022" data-vidcid="1:7:2710638" data-vidurl="https://www.nbcconnecticut.com/weather-news/video-forecast/overnight-forecast-for-february-5-2022/2710638/" data-islead="false" data-catnames="{&quot;1576&quot;:&quot;Weather&quot;,&quot;12182&quot;:&quot;Video Forecast&quot;}" data-tagnames="{&quot;29147&quot;:&quot;first alert forecast&quot;,&quot;3228&quot;:&quot;first alert weather&quot;,&quot;38249&quot;:&quot;weather forecast&quot;}" data-customdata="{&quot;ContentPartner&quot;:&quot;None&quot;,&quot;Source&quot;:&quot;WEBFM&quot;,&quot;SyndicationAllowed&quot;:&quot;true&quot;,&quot;mSNVideoCategories&quot;:&quot;MSN Video v4 Connector-most watched news&quot;,&quot;mSNVideoContentSupplierID&quot;:&quot;NBC_Local&quot;,&quot;mSNVideoCountry&quot;:&quot;us&quot;,&quot;subtitle&quot;:&quot;nosubtitle&quot;,&quot;uploadedByTeam&quot;:&quot;1&quot;,&quot;youtubeChannel&quot;:&quot;None&quot;}" data-autoplay="false" data-cplay="true"></div>
<div class="video_caption" data-react-component="NBCTruncate" data-maxlines="2" data-maxlinesmobile="4" data-readmore="Read more" data-text="" data-ellipsis="false">
							
						</div>
<p>In Canaan, Sarah Jane Polek had to improvise to clear her car off after working all day.</p>

<p>“Tic Tacs are the way I’m scrapping my car tonight," said Polek. “I don’t like the winter but I enjoy every moment of every day because it changes.”</p>

<p>Connecticut State Police tells us they responded to several accidents and calls from drivers needing help. They offered some tips for the public.</p>

<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<em>Be prepared for your day and week ahead. </em><a href="https://www.nbcconnecticut.com/newsletters/"><em>Sign up for our</em> weather newsletter.</a></blockquote>
</div>

<p>"Slow down below the speed limit, keep extra space between you and the other motorist around you," said Trooper Pedro Muniz. "Don’t make any abrupt maneuvers, don’t slam on your brakes, ease off of the gas."</p>

<p>State police also mentioned that they will be making their patrols throughout the night just in case someone needs help or there's an accident.</p>

									</div>
								<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcconnecticut.com/tag/wintry-mix/">Wintry Mix</a><a class="article-tags__tag" href="https://www.nbcconnecticut.com/tag/snow/">snow</a><a class="article-tags__tag" href="https://www.nbcconnecticut.com/tag/norfolk/">Norfolk</a><a class="article-tags__tag" href="https://www.nbcconnecticut.com/tag/sleet/">sleet</a><a class="article-tags__tag" href="https://www.nbcconnecticut.com/tag/freezing-rain/">freezing rain</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F&#038;Wintry%20Mix%20Creates%20Icy%20Conditions%20for%20Northwest%20CT?_osource=db_npd_nbc_wvit_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Wintry%20Mix%20Creates%20Icy%20Conditions%20for%20Northwest%20CT&#038;url=https%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F?_osource=db_npd_nbc_wvit_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Wintry%20Mix%20Creates%20Icy%20Conditions%20for%20Northwest%20CT%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcconnecticut.com%2Fweather-news%2Fstories%2Fwintry-mix-creates-icy-conditions-for-northwest-ct%2F2710623%2F?_osource=db_npd_nbc_wvit_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				article: 'auto',
				url: ''
			});
						_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'mix'
			});
						_taboola.push({
				flush: true
			});
		};
	</script>
		<div id="mobile-native-below-article"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
					</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_medal_count-2" class="widget widget_nbc_medal_count">
<div class="medal-count-container">
	<div class="medal-count-info">
		<div class="medal-count-logo">
			<img src="https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/src/images/olympics-beijing-2022.png" class="" />		</div>
		<div class="medal-count-title">Medal Count</div>
		<div class="medal-count" data-react-component="MedalCountWidget"></div>
	</div>
			<div class="medal-count-cta">
			<a data-lpos="olympics medal count" data-lid="see full olympic coverage" href="https://www.nbcconnecticut.com/news/sports/beijing-winter-olympics/" target="_blank">see full olympic coverage</a>
		</div>
	</div>
<div class="medal-count-ad">
	<div id="div-gpt-ad-olympicsbox_medal-count-widget" class=" gpt-olympicsbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'olympicsbox_medal-count-widget', format: 'olympicsbox', targeting: {"module":"medals","slot":"olympicsbox","pos":"olympicsbox"} });
			</script></div>
</section><section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_997" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_997', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Hartford, CT"></div>
	<a class="weather-module__conditions" href="https://www.nbcconnecticut.com/weather/">
		<div data-react-component="IframeConditions" data-location="6096"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_489" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_489', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_518" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_518', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-827381723" class="module-civicScience" data-tgtid="5e1f4541-07b8-c184-6dd9-7b8ff513b541"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_142" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_142', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_298" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_298', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_883" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_883', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcconnecticut.com/" class="site-footer__logo">
					<img
						src="https://media.nbcconnecticut.com/2021/04/CT@3x.png?fit=216%2C120&#038;quality=85&#038;strip=all"
						alt="NBC Connecticut"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="http://www.facebook.com/NBCConnecticut" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcconnecticut" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcconnecticut" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2175766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2175766"><a href="/investigations/submit-tip/">Submit Tips for Investigations</a></li>
<li id="menu-item-2175709" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2175709"><a href="https://www.nbcconnecticut.com/newsletters/">Newsletters</a></li>
<li id="menu-item-2175710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2175710"><a href="https://www.nbcconnecticut.com/contact-us/">Contact Us</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1942066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942066"><a href="https://publicfiles.fcc.gov/tv-profile/WVIT">WVIT Public Inspection File</a></li>
<li id="menu-item-2352475" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2352475"><a href="https://www.nbcconnecticut.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1942067" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942067"><a href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_Connecticut/">Privacy Policy</a></li>
<li id="menu-item-2154770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2154770"><a href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_Connecticut/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1942081" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1942081"><a href="https://www.nbcconnecticut.com/wvit-employment-information/">WVIT Employment Information</a></li>
<li id="menu-item-1942080" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1942080"><a href="https://www.nbcconnecticut.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-1942069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942069"><a href="mailto:WVITViewerMail.Advertising@nbcuni.com?subject=Advertise%20with%20Us%20HP/">Advertise with us</a></li>
<li id="menu-item-1942079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1942079"><a href="https://www.nbcconnecticut.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2305921" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2305921"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_Connecticut">CA Notice</a></li>
<li id="menu-item-1942068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1942068"><a href="https://www.nbcuniversal.com/privacy/cookies#accordionheader2">AdChoices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2022 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "nbcconnecticut.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "stories";
		_sf_async_config.authors  = "Dominique Moody";
		_sf_async_config.title    = "Wintry Mix Creates Icy Conditions for Northwest CT";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			var loaderUrl, scriptType;
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '2710623' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

						scriptType = 'tb_loader_script';
			loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			scriptType);

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-wvit\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcconnecticut.com/weather-news/stories/wintry-mix-creates-icy-conditions-for-northwest-ct/2710623/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcconnecticut.com/">
					<img
						src="https://media.nbcconnecticut.com/2021/04/CT@3x.png?fit=216%2C120&#038;quality=85&#038;strip=all"
						alt="NBC Connecticut"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcconnecticut.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Top Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/top-video-ott/">
					Top Video				</a>
							<a data-lid="Submit Photos and Videos" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcconnecticut.com/ugc/">
					Submit Photos and Videos				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="U.S. &amp; World" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. &amp; World				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="First Alert Weather Blog" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcconnecticut.com/weather-news/stories/firstalertforecast/81047/">
					First Alert Weather Blog				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="School Closings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/school-closings/">
					School Closings				</a>
							<a data-lid="Sign Up For School Closing Text Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://my.textcaster.com/asa/1775">
					Sign Up For School Closing Text Alerts				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Investigations" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a data-lid="Connecticut In Color" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/community/connecticut-in-color/">
					Connecticut In Color				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="CT Live" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/ct-live/">
					CT Live				</a>
							<a data-lid="Kids Connection" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/community/kids-connection/">
					Kids Connection				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Dog House" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/dog-house/">
					Dog House				</a>
							<a data-lid="Community" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/community/">
					Community				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Connect To Healthier" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/health/connecttohealthier/">
					Connect To Healthier				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="Submit a Consumer Complaint" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Submit a Consumer Complaint				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcconnecticut.com/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Contests" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/on-air/contests/">
					Contests				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcconnecticut.com/newsletters/">
					Newsletters				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="http://www.facebook.com/NBCConnecticut" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbcconnecticut" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbcconnecticut" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.nbcconnecticut.com/_static/??-eJyd0LFuxCAMBuAX6kFCCIGh6tCpS3Vbx8rYpheJQBTIne7ty90TtJk8+P8/WZa39YQ5VU5V1gsvXGTyeCoV6pyTxDg/Nn6fI0ksRS5MEN/znurXTD9cBblhVMNEoLhzVpMiZcUyJ9HSL/K/ei71nNc9wiZUxzAFFyanbejtoKzVh+GQc+VNEA3Ba41mRDQWXG88HTfjPe/1E65Ct1sdeoSxodYbzeQPszeGFts+WqeICWkgjx0Cj6FDdCGEv8rPiU9zjXDn7bss7Q2XR/dtee2N1p3qe+N+Aamht8w=' type='text/css' media='all' />
<script src='https://www.nbcconnecticut.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/i18n.min.js?ver=4ab02c8fd541b8cfb8952fe260d21f16' id='wp-i18n-js'></script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.21' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/url.min.js?ver=d80b474ffb72c3b6933165cc1b3419f6' id='wp-url-js'></script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/hooks.min.js?ver=63769290dead574c40a54748f22ada71' id='wp-hooks-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/dist/api-fetch.min.js?ver=0bb73d10eeea78a4d642cdd686ca7f59' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/common.56e7b20ae0d7732f3867.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.4c15723b488ed01f093e.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/global.024a9d5c8f45734ea1f0.bundle.min.js?ver=1.0.2' id='nbc-global-js'></script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/article.8551b8cf1400c2162a2f.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/static/js/zepto.min.js?ver=1.0.2' id='zepto-js'></script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/static/js/player.6.1.3.js?ver=1.0.2' id='pdk-js'></script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.2aaf2e5451de9c7a5627.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.8' id='sharethrough-js'></script>
<script async src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.57fd800295608226f92a.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/articleContent.002368ae3a0d6363e579.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.nbcconnecticut.com/wp-includes/js/wp-embed.min.js?ver=5.5.8' id='wp-embed-js'></script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/medalCountWidget.67ee7cb5b1e27a36bd71.bundle.min.js?ver=1.0.2' id='nbc-medal-count-widget-js'></script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/mostPopular.d66100ae93858ea07733.bundle.min.js?ver=1.0.2' id='nbc-most-popular-js'></script>
<script src='https://www.nbcconnecticut.com/wp-content/themes/nbc-station/client/build/js/civicScience.4db1dfb9fe92d553e9e3.bundle.min.js?ver=1.0.2' id='civic-science-js'></script>
<script src='https://stats.wp.com/e-202205.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596134',post:'2710623',tz:'-5',srv:'www.nbcconnecticut.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596134', '2710623' ]);
</script>

</body>
</html>
